Skip Ribbon Commands
Skip to main content

Quick Launch

Todd Klindt's home page > Todd Klindt's SharePoint Admin Blog > Posts > March 2013 Update for SharePoint 2013 and friends is out
March 17
March 2013 Update for SharePoint 2013 and friends is out

On Tuesday March 12, 2013 Microsoft released the first update for SharePoint 2013. It, along with the patches for Workflow Manager and the Office Web Apps are a pretty significant upgrade to the SharePoint 2013 platform. As always, you can find all the patch information at http://www.toddklindt.com/sp2013builds. Here are the patches, their links, and some notes on each.

SharePoint 2013 Patch

Build 15.0.4481.1005

SharePoint Foundation - KB2768000 - Download

SharePoint Server - KB2767999 - Download

Project Server - KB2768001 - Download

You only need to install the patch for the product you have, you don’t need to install the patches for the lower packages. So if you have SharePoint Server, you don’t need to install the Foundation patch first. These patches also have these three notes at the beginning:

  • This cumulative update package includes all the server component packages. Additionally, this cumulative update package updates only those components that are installed on the system.
  • A change in the package configuration was introduced after SharePoint Server 2013 was released. You must install this public update before you install later SharePoint updates.
  • Important When you install the cumulative update on a single-server SharePoint farm or on SharePoint servers that include Search Service Application topology roles, you must follow the steps that are mentioned on the following Microsoft website: http://go.microsoft.com/fwlink/?LinkId=279911

The first note reiterates that you only need to install one patch. The second note says you have to install this patch to install and later patches. Unlike the guidance I normally give, you should install this patch as soon as you’ve tested it and determined it doesn’t break anything. The third note says you should read this blog post before installing the patch to get some guidance on how to handle Search during the upgrade.

I’ve installed this patch on a couple of servers and its been fine.

Office Web Apps 2013 Patch

It’s not part of SharePoint anymore, but the Office Web Apps are an important party of your SharePoint 2013 farm. They got some patch love as well. Here are the links:

Office Web Apps - KB2760445 – Download

The patching process for the OWAs is different than the regular SharePoint patching process. SharePoint MCM Wictor Wilén has an excellent blog, Patching your WAC farm with no downtime, that you should read before you attempt the patching process. While you’re reading that, read Wictor’s next blog post, Enabling PDF Previews with Office Web Apps 2013 march 2013 update, to see how to add PDF support to the OWAs after you patch it. While this KB article is about a previous patch, it covers some of the new functionality that is introduced. I have seen some reports of the new version of OWA causing some issues, so be sure to test in your test environment first.

Workflow Manager Patch

Build 1.0.30207.2

Service Bus – KB2799752Download

Workflow Manager – KB2799754Download

You’ll need to install the Service Manager patch before the Workflow Manager patch. If either of them fail, reboot and try again. A couple of times that I’ve installed them they’ve been fussy, but a reboot always cheered them up.

 

There you go, there are all the patches I know about now. Let me know if you have any problems.

tk

ShortURL: http://www.toddklindt.com/March2013patches

Comments

Patching results

Hey Todd,

Thanks for the links to the SB and WM patches, I didn't even think about those. Just wanted to pass along my results on a farm with Project Server and see if anyone else got this. When I patched, the SP Config Wizard failed at the end because it couldn't upgrade the PWA site until the PWA database was upgraded. Not sure why it didn't do that one automatically, but I was able to kick that off via powershell without issues, then upgrade the PWA instance the same way. I searched (briefly) to see if there was any patching guidance specifically for Project Server 2013 but didn't find anything.

Outside of that, my BDC database also didn't get upgraded so it's sitting in a "Database is in compatibility range and upgrade is recommended" status.

I also keep seeing a compatibility range event log entry for my My Sites database, even though it is upgraded (according to powershell and the Manage Database Upgrade Status page).

Nothing really broke though, so I can't complain too much for the first big 2013 patch!
 on 3/18/2013 2:10 PM

Re: Patching results

Thanks for the feedback. I had the same issue with the BDC database not upgrading. I don't have any BDC connections defined, so I'm not sure if it's all working or not. I'm also experiencing some intermittant issues with the MMS. I haven't checked the MySites.

I'm keeping my eye on this patch.

tk
Todd O. KlindtNo presence information on 3/18/2013 4:21 PM

PU vs CU

Why are they calling this a PU instead of a CU? Is it because it's required?
 on 3/21/2013 9:15 AM

Log Folder Permissions

Also check your LOGS folder (default 15\LOGS), as I noticed for me it no longer included WSS_ADMIN_WPG or WSS_WPG, which was leading to a number of errors
 on 3/21/2013 3:38 PM

Re: PU vs CU

Todd O. KlindtNo presence information on 3/22/2013 8:14 AM

Workflow Manager not working after PU

Hey Todd,

thanks for the great information.
After applying the SP, SB and WFM patches in this order, everything seems to be fine... except for the workflow manager. The service does not come any more - not even after several restarts.

Error in the log is 401 unauthorized but I don't find anything in the logs on who wants to access what.

Do you have any hint?
 on 3/25/2013 5:15 AM

No likes or microblogging after patch

Hey Todd,

Just finished installing the patch and I no longer have likes or messages in my newsfeed.  I had to detach and attach the content DB at one point, is that why this stuff cleared?  My follows and tags are still ok but I can't see any of my microblogs.  Just a test environment so no big deal but I am not seeing a lot online so I thought I would run it by you.

Thx
 on 4/3/2013 2:30 PM

March PU Update Failed to Install

Anyone get "This package failed to install." message while trying to apply it?
 on 4/4/2013 8:58 AM

Re: March PU Update Failed to Install

I haven't gotten that error. I hope you find a solution.

tk
Todd O. KlindtNo presence information on 4/4/2013 10:22 PM

slipstream

Hi Toodd,

Can we create slipstream like SP 2010 , you had explained in http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=295 

Thanks.
 on 4/8/2013 8:30 AM
1 - 10Next

Add Comment

Items on this list require content approval. Your submission will not appear in public views until approved by someone with proper rights. More information on content approval.

Title


Body *


Today's date *

Select a date from the calendar.
Please enter today's date so I know you are a real person

Twitter


Want a message when I reply to your comment? Put your Twitter handle here.

Attachments

 

 Please Support my Sponsors