Skip Ribbon Commands
Skip to main content

Quick Launch

Todd Klindt's home page > Todd Klindt's SharePoint Admin Blog > Posts > The SharePoint 2013 Forgotten Prerequisites
April 21
The SharePoint 2013 Forgotten Prerequisites

The SharePoint 2013 installation experience lovingly includes a Prerequisite installer that installs a bunch of, well, prerequisite files for SharePoint 2013. You need to run this before you can install SharePoint 2013 on a server. The Prereq installer does an admirable job, but it doesn’t do the job 100%. Depending on which OS you’re using, Windows 2008 R2 or Windows 2012, you may need up to three additional patches to have a truly content SharePoint 2013 server. Here are the list of additional patches:

KB 2554876 - The SharePoint parsing process crashes in Windows Server 2008 R2

KB 2708075 - FIX: IIS 7.5 configurations are not updated when you use the ServerManager class to commit configuration changes in Windows 2008 R2

KB 2759112 - A hotfix is available for the .NET Framework 4.5 that resolves an ASP.NET race condition issue in Windows Server 2008 R2Download

KB 2765317 - A hotfix is available for the .NET Framework 4.5 that resolves an ASP.NET race condition issue in Windows Server 2012Download

If you try to install a patch it says it’s already installed, or you don’t need it, that’s okay. We went through this same thing with SharePoint 2010 and eventually all the necessary patches dribbled out in Windows Update. Also, if you have already installed SharePoint 2013 it’s safe to install these after the fact.

I got this list of patches from TechNet in the Hardware and software requirements for SharePoint 2013 document.

Enjoy,

tk

ShortURL: http://www.toddklindt.com/sp2013forgottenprereqs

Comments

Are they really required on DB servers as well?

Hi Todd,

have you noticed on TechNet article that they asked us to install these hot fixes on DB server as well.. have you noticed that? I am not sure they are really required on DB servers.. What you say?

Thanks for posting this article..

Thanks,
Nik
 on 4/21/2013 9:27 PM

Pre-Requisite Installer

Would you recommend integrating these into the prerequisite installer?
 on 5/21/2013 4:17 PM

Upgrade to SP2013

In preparation for  the upgrade to Sharepoint 2013 I need to move all my sharepoint 2010 standard edition  site collections “32” which they are in separate Databases  content (SQL 2012)  in one database content so I can run mount powers shell command to web application ,  I get the error :
Move-SPSite : Site collection http://sss database “name”. Site collection will not be moved
At line:1 char:12
+ Move-SPSite <<<<  -Identity http://ssssss -DestinationDatabase name     + CategoryInfo          : InvalidData: (Microsoft.Share...PCmdletMoveSite:SPCmdletMoveSite) [Move-SPSite], SPCmdle    tException     + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletMoveSite
Any help will be appreciated
Thanks
Nino2009
 on 5/21/2013 4:31 PM

Site Collection  moving  throw error “site collection already exist Site collection will not be moved”

In preparation for  the upgrade to Sharepoint 2013 I need to move all my sharepoint 2010 standard edition  site collections “32” which they are in separate Databases  content (SQL 2012)  in one database content so I can run mount powers shell command to web application ,  I get the error :

“Move-SPSite : Site collection http://sss database “name” already exists in database . Site collection will not be moved
At line:1 char:12
+ Move-SPSite <<<<  -Identity http://ssssss -DestinationDatabase name     + CategoryInfo          : InvalidData: (Microsoft.Share...PCmdletMoveSite:SPCmdletMoveSite) [Move-SPSite], SPCmdle    tException     + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletMoveSite”


Any help will be appreciated
Thanks
Nino2009
 on 5/22/2013 8:49 AM

Thank you!

This helped me a lot .. :)
 on 1/17/2014 4:21 AM

Thanks Todd!

Very helpful.  Appreciate the download links for the hotfixes as well. 

Bryan
 on 2/25/2014 8:20 AM

Re: Thanks Todd!

You're very welcome.
Todd O. KlindtNo presence information on 2/25/2014 8:24 AM

Server 2012 R2

Since 2012 R2 is now supported, are there additional pre-reqs, or are they the same as 2012?
 on 6/10/2014 9:55 AM

Re: Server 2012 R2

The prereqs are different. That's why you can't slipstream SP1 into an RTM install of SharePoint 2013 and have it work on Windows 2012 R2. Slipstreaming doesn't update the Prereqinstaller.exe file to reflect the new prereqs. I have recently tried to install the Windows 2012 forgotten prereq on Windows 2012 R2 and it told me it was not applicable to my system.

tk
Todd O. KlindtNo presence information on 6/10/2014 10:06 AM

Server 2012 R2

Since 2012 R2 is now supported, are there additional pre-reqs, or are they the same as 2012?
 on 6/10/2014 10:06 AM
1 - 10Next

Add Comment

Items on this list require content approval. Your submission will not appear in public views until approved by someone with proper rights. More information on content approval.

Title


Body *


Today's date *

Select a date from the calendar.
Please enter today's date so I know you are a real person

Twitter


Want a message when I reply to your comment? Put your Twitter handle here.

Attachments

 

 Please Support my Sponsors